Este tópico contém respostas, possui 2 vozes e foi atualizado pela última vez por  Diogo Zimmermann 4 dias .

Visualizando 15 posts - 16 até 30 (de 58 do total)
  • Autor
    Posts
  • #169341

    TheCranio3000
    Participante

    amigo, testei o código, porem quando coloco a opção 2, para ele girar mais devagar, ele simplismente não gira, fica parado, e se eu mudar a velocidade rápida para 150, ele tambem nao giram em nenhuma das opções, sabe me dizer o porque? sera que nao consigo usar essa ponte entao?

    0
    #169400

    Como assim, opção 2?

     

    Diogo – Equipe FilipeFlop

    0
    #169407

    TheCranio3000
    Participante

    no monitor serial da programação, mas imagino que é devido a tensão minima do motor, por isso.

    0
    #169411

    Tente medir a tensão no motor para ver se está sendo alimentado corretamente.

     

    Diogo – Equipe FilipeFlop

    0
    #169575

    TheCranio3000
    Participante

    sabe algum código que eu possa testar o modulo sensor ir 5 canais?

    0
    #169586

    O código do carrinho deve funcionar para testar.

     

    Diogo – Equipe FilipeFlop

    0
    #169589

    O código do carrinho deve funcionar para testar.

     

    Diogo – Equipe FilipeFlop

    0
    #169600

    TheCranio3000
    Participante

    https://portal.vidadesilicio.com.br/robo-seguidor-de-linha-sensor-infravermelho-e-pwm/, sabe se eu consigo usar esse código na ponte h l9110s?

    0
    #169616

    Sim, só precisa adaptar ele para as entradas e saídas da sua ponte H

     

    Diogo – Equipe FilipeFlop

    0
    #174592

    TheCranio3000
    Participante

    amigo, tens algum exemplo de programação pronta para utilizar o sensor ir 5 canais? ele funciona de modo analogico, certo?

    0
    #174656

    TheCranio3000
    Participante

    outra duvida, esse sensor https://www.filipeflop.com/produto/modulo-sensor-ir-5-canais-para-robo-seguidor-de-linha/#tab-blogrelacionados, é ligado na entrada analogica ou ele é digital?

    0
    #174996

    Ele tem saída digital.

     

    O código exemplo desse tutorial já serve para usar ele: https://www.filipeflop.com/blog/projeto-robo-seguidor-de-linha-arduino/

     

    A única diferença é que os pinos S1/S2 e etc devem ser conectados no Arduino como está no código.

     

    Abraços!

     

     

    0
    #175007

    TheCranio3000
    Participante

    mas no código ele está como analogRead(0), entao eu teria que ligar ele nos pinos analogicos do arduino? nao entendi, ligo nos pinos analogico ou digitais?  outra coisa, como faço para melhorar o desempenho dele, pois dependendo da iluminação ele nao funciona muito bem ele identifica a sombra como a linha preta

    0
    #175008

    Serão nos pinos analógicos mesmo.

     

    Tente ligá-lo em um lugar claro para evitar esse tipo de problema.

     

    Att

    0
    #175009

    TheCranio3000
    Participante

    tentei fazer isso, porem a sombra que fica embaixo da placa atrapalha e ele nao faz a leitura corretamente, se eu colocar a lanterna do celular pra clarear tambem nao resolve, será que um led infra vermelho daria certo?

    0
Visualizando 15 posts - 16 até 30 (de 58 do total)

Você deve fazer login para responder a este tópico.