Este tópico contém resposta, possui 2 vozes e foi atualizado pela última vez por  André Rocha 1 mês .

Visualizando 2 posts - 1 até 2 (de 2 do total)
  • Autor
    Posts
  • #86520

    Ramon
    Participante

    Olá,

    Preciso de ajuda com esse projeto, poderiam me ajudar por favor?

    Quero utilizar um ESP8266 para ligar e desligar um relé pela internet através de WebSocket.

    Do lado esquerdo da protoboard está com 3V para alimentar o ESP8266 e o lado direito 5V para alimentar o relé.

    Entre os dois utilizo um Conversor de Nível Lógico bidirecional para comunicação entre os dois.

    No ESP8266 utilizo o GPIO2 para controlar o relé.

    A parte do WebSocket está funcionando legal, o problema é que não estou conseguindo acionar o relé.

    Quando ligo a fonte da protoboard a lâmpada conectada ao relé dá um flash (acende e logo apaga rapidamente), como se tivesse dando uma sobrecarga ao ligar a fonte.

    Alguém teria alguma ideia do motivo pelo qual não consigo acionar o relé?

    Desde já agradeço!

    0
    #86699

    André Rocha
    Moderador

    Olá Ramon!

    Acho que você precisa alimentar o seu conversor lógico bidirecional, para ele saber a tensão que precisa fornecer.

    Outra coisa que você pode fazer, se não funcionar, é colocar um transistor como chave. Aí Você coloca os 3,3 V e ele liga o relé com os 5 V da própria fonte, como se fosse um pequeno relé.

    Vai nos avisando se funcionou!

    0
Visualizando 2 posts - 1 até 2 (de 2 do total)

Você deve fazer login para responder a este tópico.